Friday, May 18, 2018

My Experiences Updating VCSA 6.5a to 6.5 U2

Today we'll be updating my lab's VCSA 6.5a (build 4944578) to version 6.5 Update 2 (build 8307201) which was released  May 3 2018. vCenter Server 6.5 U2 includes some backported features of vSphere 6.7 making it a slick update for users not quite ready to move to version 6.7. Some of the new features include

NOTE: Currently, upgrading from vSphere 6.5 U2 to vSphere 6.7 GA is not supported

You can verify your VCSA version by clicking on the top most level of the hierarchy tree in the vSphere Web Client and viewing the Summary tab


Before I perform this update, I'm going to verify compatibility with my registered and connected solutions with the VMware Interoperability Matrix

Then, I'm going to login to the vCenter Server Appliance Management Interface (VAMI) at <https://fqdn-of-vc:5480and ensure overall Health Status is green, take a VM-level snapshot (not pictured) and create a native VCSA Backup.



Upon entering my Backup details and clicking Next, I got a message stating that the service 'statsmonitor' wasn't running



A quick SSH session to the VCSA and running service-control --start vmware-statsmonitor resulted in starting the service



This allowed the Backup to continue


After it validated the input, we're ready to click Finish, which initiated the backup and showed a Backup Progress Bar



With our VM snapshot and VCSA Backup in place, we're ready to go to the Update section of the VAMI and check for Updates


Click Install Updates and accept the EULA to begin the update. My update jumped straight to 40% with status "Start staging packages" then had a "Download Failed"



At this point, I took a break for the evening (hey can't a man eat and unwind with some SNES Classic?!) and revisited it in the morning. This time, I did a tail -f on /var/log/vmware/applmgmt/software-packages.log to watch the progress of the downloads and to my surprise, the downloads worked this time without any changes made. If you run into a similar error, I would review this log to see what could be causing the downloads to fail (proxy config, incorrect URL, etc).

The Update window status changed to "Start running pre-install scripts"



Then made its way to 100% with the message "Packages upgraded successfully, reboot required to complete the installation"



And checking the software-packages.log we can confirm the packages were properly staged and ready for reboot



Clicking OK, I proceeded to the Summary Tab where I could click Reboot



Upon logging back in to the VAMI, we can verify the new build version!


Confirming in vSphere Web Client


Remember, we haven't fully upgraded to vSphere 6.5 U2 until the ESXi hosts are also updated. The embedded VUM instance in VCSA 6.5 makes that an almost effortless task.

Thanks for reading and good luck with your updates!
Share:

Follow by Email