Monday, December 9, 2019

Upgrading AMDGPU 18.50 to 19.30 on Ubuntu 18.04



Hope you find this post helpful. My system is running Ubuntu 18.04.3 LTS with an AMD Ryzen 5 2400g and a separate Radeon RX 570 GPU.

Steam gameplay isn't perfect, but it's certainly good enough for my needs (minor screen tearing on most games, but it's not to the point of being overwhelmingly annoying or distracting).

Running sudo apt list --installed |grep -i amdgpu-pro reveals that I'm running the amdgpu-pro driver version 18.50-708488

Amdgpu 19.30 was released November 5th 2019 and can be found here: https://www.amd.com/en/support/kb/release-notes/rn-rad-lin-19-30-unified and is only compatible with the following distros/versions:
  • Ubuntu 18.04.3
  • RedHat Enterprise Linux 8.0
  • RedHat Enterprise Linux 7.6
  • CentOS 8.0
  • CentOS 7.6
  • SLED/SLES 15 SP1

Performing the Upgrade

1. Backup Backup Backup. Be sure you have proper backups and restore mechanisms in place. For my system, I use multiple backup solutions including Timeshift, as well as daily, weekly, and monthly Rsync backups. 
2. Download the 19.30 driver for your system (Ubuntu 18.04.3 version available here)
3. Extract the archive, either using Ubuntu's GUI or using tar -Jxvf
4. CD into the resulting directory and run the installer:  sudo ./amdgpu-pro-install

You'll find that the installer will list a number of packages to be upgraded. Go ahead and choose the default Y by hitting Enter and it will progress through the upgrade. Note you'll see it "Deleting module verison 18.50" during the 19.30 installation.

Once complete, you won't get any obvious "Complete!" or "Success!" prompts, but will rather be taken back to the command prompt. If you scroll up a bit, you should see the message "DKMS: install completed."

Assuming you don't see any errors mentioned, go ahead and reboot. You can verify 19.30 is the current driver by running sudo apt list --installed |grep -i amdgpu-pro again. 

Vulkan

Now, keep in mind that in order to use the Vulkan driver, Vulkan must be SDK needs to be at version 1.1.109.0, per the official documentation above. Running vulkaninfo should show you what Vulkan Instance Version you have. In my case, I had 1.1.70 installed, so an update was needed. You'll find that 1.1.109 isn't available over at https://vulkan.lunarg.com/sdk/home. For the meantime, I have simply installed the latest SDK at version 1.1.126 (the latest available at the time of this writing). If you run into this issue as well, please upvote and comment over here: https://community.amd.com/message/2941548

Good luck!
Share:

0 comments:

Post a Comment

Follow by Email